PHP is among the most commonly used server-side programming languages. It’s exceptionally popular as it is free software, which you can use to build interactive websites like social networks, e-stores or online teaching websites instead of static HTML sites. A PHP module must be present on the server where a PHP-powered website is hosted so that its code can be ‘decrypted’. As there aren’t any license taxes for this sort of module and the language provides incalculable options for the Internet applications that you develop, there are 100s of millions of PHP-powered sites. On top of that, there’re lots of open-source PHP scripts, which you can use for your sites without having to possess any programming know-how. As there’re a couple of versions of PHP, you should verify that the same version that you used whilst setting up your site is installed on the web server as well.

PHP 4, PHP 5 and PHP 7 Support in Shared Website Hosting

With our Linux shared website hosting packages, you will be able to choose the PHP version that will be active for your web hosting account, since several versions are supported on our servers. With as little as one click of the mouse, you’ll be able to switch between PHP 4, 5, 7 and each time a new version is launched in the future, we’ll include it in the Hepsia hosting Control Panel without removing the previous ones. In this way, you will be able to host all the websites that you’ve created over the years. Unlike many other hosting suppliers, we will not compel you to update such websites, as a script may be out of date, but this doesn’t mean that it is insecure as you may have performed modifications to its code to prevent security holes. For the sake of your convenience, you’ll even be able to pick a different PHP version for each website hosted in your shared account.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

In case you have a site created using an older PHP version and you’ve donated time and effort to setting it up, repairing safety holes and entering page content, you’ll need a web hosting service that can support it, since most web hosting vendors nowadays support only the most recently published PHP version and remove the older ones. We, however, have decided to let you choose the version that your own websites need. Our semi-dedicated packages support PHP 4, PHP 5 and PHP 7, which means that you’ll be able to use both older and newer scripts without losing any manual tweaks or frittering away time and effort struggling to make your websites compatible with the hosting platform. The current version can be changed via the Hepsia hosting Control Panel and such an update will apply to the whole account, but you will also be able to set a different PHP version for each site hosted in your account using an .htaccess configuration file.